summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Chantry <chantry.xavier@gmail.com>2010-03-15 23:46:44 +0100
committerDan McGee <dan@archlinux.org>2010-05-18 11:30:29 -0500
commitd44e5099339616c29797b88ed19fe27ea282c9ae (patch)
tree09a8d48841895a54da03d7303e8d70f540e9da15 /configure.ac
parentd32f6daa66a454ea41574667d44a2f6c36d4f77e (diff)
downloadpacman-d44e5099339616c29797b88ed19fe27ea282c9ae.tar.gz
pacman-d44e5099339616c29797b88ed19fe27ea282c9ae.zip
configure.ac : disable doc by default and check for asciidoc
This is a complaint that has been reported many many times. By default, docs are enabled and there is no check for asciidoc, so anyone building from git will see their build fail. We cannot do a strict check for asciidoc because released source tarballs have man pages already built, and it should be possible to install them without having asciidoc. This patch attempts to improve the situation in two ways : 1) disable doc by default 2) print a warning if docs are enabled but asciidoc is not installed Signed-off-by: Xavier Chantry <chantry.xavier@gmail.com> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 11 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 4307fb1b..008fa75d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,8 +100,8 @@ AC_ARG_ENABLE(internal-download,
# Help line for documentation
AC_ARG_ENABLE(doc,
- AS_HELP_STRING([--disable-doc], [prevent make from looking at doc/ dir]),
- [wantdoc=$enableval], [wantdoc=yes])
+ AS_HELP_STRING([--enable-doc], [run make in doc/ dir]),
+ [wantdoc=$enableval], [wantdoc=no])
# Help line for doxygen
AC_ARG_ENABLE(doxygen,
@@ -261,12 +261,18 @@ AC_SUBST(CARCHFLAGS)
AC_SUBST(CHOST)
# Check for documentation support and status
+AC_CHECK_PROGS([ASCIIDOC], [asciidoc])
AC_MSG_CHECKING([for building documentation])
if test "x$wantdoc" = "xyes" ; then
- AC_MSG_RESULT([yes])
+ if test $ASCIIDOC ; then
+ AC_MSG_RESULT([yes, enabled by configure])
+ else
+ asciidoc="(warning : asciidoc not installed)"
+ AC_MSG_RESULT([yes $asciidoc])
+ fi
wantdoc=yes
else
- AC_MSG_RESULT([no, disabled by configure])
+ AC_MSG_RESULT([no])
wantdoc=no
fi
AM_CONDITIONAL(WANT_DOC, test "x$wantdoc" = "xyes")
@@ -389,7 +395,7 @@ ${PACKAGE_NAME}:
build script name : ${BUILDSCRIPT}
Compilation options:
- Run make in doc/ dir : ${wantdoc}
+ Run make in doc/ dir : ${wantdoc} ${asciidoc}
Use download library : ${internaldownload}
Doxygen support : ${usedoxygen}
debug support : ${debug}