summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Chantry <shiningxc@gmail.com>2009-08-10 16:29:37 +0200
committerDan McGee <dan@archlinux.org>2009-08-18 20:38:08 -0500
commit8a55b793631f37dbe7f906cd55d0997f920d36e8 (patch)
tree0899dff0904da75ec9ad06013eacfc088701dc01 /configure.ac
parentbba234a92ed9560bab1f1846870faa8303f98064 (diff)
downloadpacman-8a55b793631f37dbe7f906cd55d0997f920d36e8.tar.gz
pacman-8a55b793631f37dbe7f906cd55d0997f920d36e8.zip
re-add -g CFLAGS with --enable-debug
after commit 8feccaed7861010caefa4f7b9824a6, -g was no longer added with --enable-debug. So if CFLAGS was set (if unset, it defaults to -g -O2) and didn't contain -g, we ended with no debug symbols.. Signed-off-by: Xavier Chantry <shiningxc@gmail.com> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 90be362e..b2164b9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -284,7 +284,7 @@ if test "x$debug" = "xyes" ; then
# Check for -fstack-protector availability
GCC_STACK_PROTECT_LIB
GCC_STACK_PROTECT_CC
- CFLAGS="$CFLAGS -Wall -Werror"
+ CFLAGS="$CFLAGS -g -Wall -Werror"
else
AC_MSG_RESULT(no)
CFLAGS="$CFLAGS -Wall"