summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2010-06-17 00:01:23 -0500
committerDan McGee <dan@archlinux.org>2010-06-17 00:01:23 -0500
commit7fc50d79508f30e74e5ea8d9c801549e7f52229d (patch)
tree92b2208801f481413369c93076a4b39e54d0f194 /configure.ac
parentdc817a2061699cd1f33ca93f0d93a1fbc2f33ea1 (diff)
downloadpacman-7fc50d79508f30e74e5ea8d9c801549e7f52229d.tar.gz
pacman-7fc50d79508f30e74e5ea8d9c801549e7f52229d.zip
Revert disabling of make in doc/ dir by default
This is a partial revert of commit d44e5099. By making disabling docs the default, it presents all sorts of problems- namely anyone who builds from a tarball and isn't careful enough to include '--enable-doc' will get an install without any manpages at all. Remember that make includes both 'build' and 'install' steps. The warning introduced by the commit is kept, so we do not lose all its benefits, but I am not happy to see regressions introduced in packaging and installing of this piece of software. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 008975b8..4faf20d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,8 +100,8 @@ AC_ARG_ENABLE(internal-download,
# Help line for documentation
AC_ARG_ENABLE(doc,
- AS_HELP_STRING([--enable-doc], [run make in doc/ dir]),
- [wantdoc=$enableval], [wantdoc=no])
+ AS_HELP_STRING([--disable-doc], [prevent make from looking at doc/ dir]),
+ [wantdoc=$enableval], [wantdoc=yes])
# Help line for doxygen
AC_ARG_ENABLE(doxygen,
@@ -272,7 +272,7 @@ if test "x$wantdoc" = "xyes" ; then
fi
wantdoc=yes
else
- AC_MSG_RESULT([no])
+ AC_MSG_RESULT([no, disabled by configure])
wantdoc=no
fi
AM_CONDITIONAL(WANT_DOC, test "x$wantdoc" = "xyes")