summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2010-05-04 23:43:43 -0500
committerDan McGee <dan@archlinux.org>2010-05-04 23:43:43 -0500
commit6b6eb6345bb3d9f59d967144968328c9a4b7873c (patch)
tree2c6fbe8029373879ddcf7c0e69c09dfb65010aaa /configure.ac
parenteb6af031ec83c4c0c1d7e12d1cc8f585197c025f (diff)
downloadpacman-6b6eb6345bb3d9f59d967144968328c9a4b7873c.tar.gz
pacman-6b6eb6345bb3d9f59d967144968328c9a4b7873c.zip
Fix up the cross-compilation patch library lookup
Don't explicitly add things to the list that might not need to be there, and get the fallback list of libraries correct. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d0fed48f..9760ba83 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,8 +142,8 @@ if test "x$internaldownload" = "xyes" ; then
AC_MSG_RESULT(yes)
AC_DEFINE([INTERNAL_DOWNLOAD], , [Use internal download library])
# Check for a download library if it was actually requested
- AC_CHECK_LIB([fetch], [fetchParseURL], [AC_SUBST([LIBS], ["-lfetch -lssl -lcrypto -ldl $LIBS"])],
- AC_MSG_ERROR([libfetch is needed to compile with internal download support]), [-lssl -lcrypto -ldl] )
+ AC_CHECK_LIB([fetch], [fetchParseURL], ,
+ AC_MSG_ERROR([libfetch is needed to compile with internal download support]), [-lcrypto -ldl] )
# Check if libfetch supports conditional GET
# (version >=2.21, struct url has member last_modified)
AC_CHECK_MEMBER(struct url.last_modified, ,