summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2010-09-23 09:10:47 -0500
committerDan McGee <dan@archlinux.org>2010-09-23 09:10:53 -0500
commitf489e969f0ca65fe210678844fabddd29a7597e1 (patch)
tree170273be3c2f0c1364f773e184f71dfb5614da60 /Makefile.am
parent413508c6fa54f465cdcf021a59ee7e6a38d5b1e7 (diff)
downloadpacman-f489e969f0ca65fe210678844fabddd29a7597e1.tar.gz
pacman-f489e969f0ca65fe210678844fabddd29a7597e1.zip
Update build system (automake, autoconf, libtool)
Unfortunately this patch is hard to split up into smaller chunks. Our build system and the associated automake/autoconf/libtool macros has been left untouched for a while, and could use a refresher. * Upgrade ltmain.sh to the latest version * Move away from a huge acinclude.m4 directory to using individual files in the m4/ subdirectory, suggested by upstream automake documentation * Update all macros to their latest available version * Adjust Makefile.am and autogen.sh to accommodate m4/ subdirectory Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f70192e9..32a08f71 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,6 +3,8 @@ if WANT_DOC
SUBDIRS += doc
endif
+ACLOCAL_AMFLAGS = -I m4 --install
+
# Make sure we test and build manpages when doing distcheck
DISTCHECK_CONFIGURE_FLAGS = --enable-doc --disable-git-version