summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2008-01-06 10:23:49 -0600
committerDan McGee <dan@archlinux.org>2008-01-06 10:23:49 -0600
commitd53388fb90ee9594e07b8f00cc45436e6318c972 (patch)
tree0c1f025fd7adaec0f787adca3393ef3a9ba51451 /Makefile.am
parente0e33c329ff249d7862a0e7ec508794faa98efd8 (diff)
downloadpacman-d53388fb90ee9594e07b8f00cc45436e6318c972.tar.gz
pacman-d53388fb90ee9594e07b8f00cc45436e6318c972.zip
install: install prototype PKGBUILD and install to datadir
Move the prototypes out of contrib/ and into the top level directory, and install them to what is usually /usr/share/pacman/ on a package install. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 307a7d68..6453555e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,10 @@ endif
# AUTHORS, COPYING, NEWS, README
EXTRA_DIST = HACKING
+# Sample makepkg prototype files
+pkgdatadir = ${datadir}/${PACKAGE}
+dist_pkgdata_DATA = PKGBUILD.proto proto.install
+
# run the pactest test suite
check-local: src/pacman
$(PYTHON) $(top_srcdir)/pactest/pactest.py --debug=1 \