summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-07-10 14:58:45 -0400
committerDan McGee <dan@archlinux.org>2007-07-10 14:58:45 -0400
commit64e45a36f868ca0386393d6b6cf05ffff09b5439 (patch)
tree23b5ee66db0541644908a635c9eb291636428f6e /Makefile.am
parentd12c4f4b29458ff04671bf7b9686735ad988c775 (diff)
downloadpacman-64e45a36f868ca0386393d6b6cf05ffff09b5439.tar.gz
pacman-64e45a36f868ca0386393d6b6cf05ffff09b5439.zip
Create the pacman DB and cachedir directories upon install
Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 039e2fbe..87bbee6a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,10 +4,17 @@ SUBDIRS = lib/libalpm src/util src/pacman scripts doc etc po pactest contrib
# AUTHORS, COPYING, NEWS, README
EXTRA_DIST = HACKING
+# run the pactest test suite
check-local: src/pacman
python $(top_srcdir)/pactest/pactest.py --debug=1 \
--test $(top_srcdir)/pactest/tests/*.py \
-p $(top_builddir)/src/pacman/pacman
rm -rf $(top_builddir)/root
+# create the pacman DB and cache directories upon install
+install-data-local:
+ for dir in "$(DESTDIR)$(localstatedir)/lib/pacman" "$(DESTDIR)$(localstatedir)/cache/pacman/pkg"; do \
+ test -z "$$dir" || $(MKDIR_P) "$$dir"; \
+ done
+
# vim:set ts=2 sw=2 noet: