summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2008-05-29 17:25:37 -0500
committerDan McGee <dan@archlinux.org>2008-05-29 17:25:37 -0500
commit2cd0a87b3f63abacaa3548ae24f764c42e00a3ff (patch)
tree0ff29a1f17422ebcc29260331d45f1b5b20389fe /Makefile.am
parentb48f703aa6da7d9863501df1488f851313998ebe (diff)
downloadpacman-2cd0a87b3f63abacaa3548ae24f764c42e00a3ff.tar.gz
pacman-2cd0a87b3f63abacaa3548ae24f764c42e00a3ff.zip
Add simple vercmp test script
Commit 84283672853350a84d2a71b72dc06e180cad1587 updated the versioncmp code in libalpm. Unfortunately for us, it also introduced the regression that becomes apparant with the following upgrade: warning: sonata: local (1.5-2) is newer than extra (1.5.1-2) Add a vercmptest.sh test script that is run during the make check phase which now points out three regressions in the version comparison function that will need fixing. All current tests in this script pass with the old versioncmp code. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index dc085429..ea3b0e07 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,12 +11,14 @@ EXTRA_DIST = HACKING
pkgdatadir = ${datadir}/${PACKAGE}
dist_pkgdata_DATA = PKGBUILD.proto proto.install ChangeLog.proto
-# run the pactest test suite
-check-local: src/pacman
+# run the pactest test suite and vercmp tests
+check-local: pactest src/pacman src/util
$(PYTHON) $(top_srcdir)/pactest/pactest.py --debug=1 \
--test $(top_srcdir)/pactest/tests/*.py \
-p $(top_builddir)/src/pacman/pacman
rm -rf $(top_builddir)/root
+ $(SH) $(top_srcdir)/pactest/vercmptest.sh \
+ $(top_builddir)/src/util/vercmp
# create the pacman DB and cache directories upon install
install-data-local: