summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2010-06-02 13:24:22 -0500
committerDan McGee <dan@archlinux.org>2010-06-02 13:24:22 -0500
commit0ac96d94ec3a8a2f3a3857810dbd9109c5cd3235 (patch)
tree78dab2f492ba21b3c185d1fd0a86d3d8cfdd0b12 /Makefile.am
parent844d82fad811626b0b8e54db60ee4b3ea32a3cb9 (diff)
downloadpacman-0ac96d94ec3a8a2f3a3857810dbd9109c5cd3235.tar.gz
pacman-0ac96d94ec3a8a2f3a3857810dbd9109c5cd3235.zip
Move vercmp tests into util/ testing directory
Now that not everything is in 'pactest/', we can separate out the parts a bit more and leave the pacman/ directory to be just pactest. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index eb80a5f1..bb7e3a72 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,12 +15,12 @@ pkgdatadir = ${datadir}/${PACKAGE}
dist_pkgdata_DATA = PKGBUILD.proto PKGBUILD-split.proto proto.install ChangeLog.proto
# run the pactest test suite and vercmp tests
-check-local: test/pacman src/pacman src/util
+check-local: test/pacman test/util src/pacman src/util
$(PYTHON) $(top_srcdir)/test/pacman/pactest.py --debug=1 \
--test $(top_srcdir)/test/pacman/tests/*.py \
-p $(top_builddir)/src/pacman/pacman
rm -rf $(top_builddir)/root
- $(SH) $(top_srcdir)/test/pacman/vercmptest.sh \
+ $(SH) $(top_srcdir)/test/util/vercmptest.sh \
$(top_builddir)/src/util/vercmp
# create the pacman DB and cache directories upon install