summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2019-06-25 16:28:16 -0400
committerAllan McRae <allan@archlinux.org>2019-06-28 10:20:53 +1000
commite7a2b2764ad0b4240f87b742fdf0c404be11af03 (patch)
tree13621eda2d8ef2254e19892007dde0d26a180e3d /meson.build
parent83f428d974ab39f24a067dd7187f62a9455804dd (diff)
downloadpacman-e7a2b2764ad0b4240f87b742fdf0c404be11af03.tar.gz
pacman-e7a2b2764ad0b4240f87b742fdf0c404be11af03.zip
meson: use not_found_message when dependencies are not found
The default state of `dependency()` is `required: true`, which means if a dependency is not found, meson immediately aborts and does not log our `error()` messages. meson 0.50 has builtin support for dependencies with custom error messages. The alternative would be to specify `required: false` everywhere, and only then to key off of `dep.found()`. Signed-off-by: Eli Schwartz <eschwartz@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 4 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index de309e30..f5fdd733 100644
--- a/meson.build
+++ b/meson.build
@@ -130,17 +130,13 @@ endif
want_crypto = get_option('crypto')
if want_crypto == 'openssl'
- libcrypto = dependency('libcrypto', static : get_option('buildstatic'))
- if not libcrypto.found()
- error('openssl support requested but not found')
- endif
+ libcrypto = dependency('libcrypto', static : get_option('buildstatic'),
+ not_found_message : 'openssl support requested but not found')
crypto_provider = libcrypto
conf.set10('HAVE_LIBSSL', true)
elif want_crypto == 'nettle'
- libnettle = dependency('nettle', static : get_option('buildstatic'))
- if not libnettle.found()
- error('nettle support requested but not found')
- endif
+ libnettle = dependency('nettle', static : get_option('buildstatic'),
+ not_found_message : 'nettle support requested but not found')
crypto_provider = libnettle
conf.set10('HAVE_LIBNETTLE', true)
else