summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2019-03-07 22:07:55 -0500
committerAllan McRae <allan@archlinux.org>2019-03-19 12:04:51 +1000
commitbbfb75fd292e3f2818cdc0eae68c292bb3fbc50b (patch)
tree06cc86d19f2c3e4fcf15ae2b1d4e3937fb60612e /meson.build
parentf26cb61cb6a16c8ce85f33e6090763aced0118c3 (diff)
downloadpacman-bbfb75fd292e3f2818cdc0eae68c292bb3fbc50b.tar.gz
pacman-bbfb75fd292e3f2818cdc0eae68c292bb3fbc50b.zip
build: remove references to variable replacements from pacman-optimize
MODECMD and OWNERCMD are not used by pacman itself, so we don't need to check for and replace them now that pacman-optimize is removed. Signed-off-by: Eli Schwartz <eschwartz@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 0 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index b810e2fb..66a6385c 100644
--- a/meson.build
+++ b/meson.build
@@ -255,8 +255,6 @@ add_project_arguments('-include', 'config.h', language : 'c')
default_duflags = ' -sk --apparent-size'
default_sedinplaceflags = ' --follow-symlinks -i'
inodecmd = 'stat -c \'%i %n\''
-ownercmd = 'stat -c \'%u:%g\''
-modecmd = 'stat -c \'%a\''
strip_binaries = '--strip-all'
strip_shared = '--strip-unneeded'
strip_static = '--strip-debug'
@@ -264,8 +262,6 @@ strip_static = '--strip-debug'
os = host_machine.system()
if os.startswith('darwin')
inodecmd = '/usr/bin/stat -f \'%i %n\''
- ownercmd = '/usr/bin/stat -f \'%u:%g\''
- modecmd = '/usr/bin/stat -f \'%lp\''
default_sedinplaceflags = ' -i \'\''
default_duflags = ' -sk'
strip_binaries = ''
@@ -273,8 +269,6 @@ if os.startswith('darwin')
strip_static = '-s'
elif os.contains('bsd') or os == 'dragonfly'
inodecmd = 'stat -f \'%i %n\''
- ownercmd = 'stat -f \'%u:%g\''
- modecmd = 'stat -f \'%lp\''
default_sedinplaceflags = ' -i \'\''
default_duflags = ' -sk'
endif
@@ -314,8 +308,6 @@ substs.set('BUILDSCRIPT', BUILDSCRIPT)
substs.set('TEMPLATE_DIR', get_option('makepkg-template-dir'))
substs.set('DEBUGSUFFIX', get_option('debug-suffix'))
substs.set('INODECMD', inodecmd)
-substs.set('OWNERCMD', ownercmd)
-substs.set('MODECMD', modecmd)
substs.set('SEDINPLACEFLAGS', sedinplaceflags)
substs.set('SEDPATH', SED.path())
substs.set('DUFLAGS', duflags)
@@ -471,8 +463,6 @@ message('\n '.join([
' Architecture : @0@'.format(carch),
' Host Type : @0@'.format(chost),
' File inode command : @0@'.format(inodecmd),
- ' File owner command : @0@'.format(ownercmd),
- ' File mode command : @0@'.format(modecmd),
' Directory size command : @0@ @1@'.format(DU.path(), duflags),
' In-place sed command : @0@ @1@'.format(SED.path(), sedinplaceflags),
' libalpm version : @0@'.format(libalpm_version),