summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2019-06-29 12:58:25 -0400
committerAllan McRae <allan@archlinux.org>2019-08-05 18:21:12 +1000
commitb3dd02236c8098f29595587714ffb1945972d60a (patch)
tree52a41dbbaec9b6bc9c5bea1a58c2083306e5ad38 /meson.build
parent4e5254dbf3ff82b9190308e5e3501f18b876c419 (diff)
downloadpacman-b3dd02236c8098f29595587714ffb1945972d60a.tar.gz
pacman-b3dd02236c8098f29595587714ffb1945972d60a.zip
meson: drop checks for things we don't use
This was ported over from the AC_CHECK_{FUNCS,HEADERS} lists in configure.ac, but I never actually checked if the resulting CPP defines are used. Turns out, lots of symbols, not a lot of define usage. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 0 insertions, 25 deletions
diff --git a/meson.build b/meson.build
index db9e9349..fe4269dc 100644
--- a/meson.build
+++ b/meson.build
@@ -136,38 +136,13 @@ foreach header : [
endforeach
foreach sym : [
- 'dup2',
- 'fork',
- 'getcwd',
'getmntent',
'getmntinfo',
- 'gettimeofday',
- 'memmove',
- 'memset',
- 'mkdir',
- 'realpath',
- 'regcomp',
- 'rmdir',
- 'setenv',
- 'setlocale',
- 'strcasecmp',
- 'strchr',
- 'strcspn',
- 'strdup',
- 'strerror',
'strndup',
'strnlen',
- 'strnlen',
- 'strrchr',
- 'strsep',
'strsep',
- 'strstr',
- 'strtol',
'swprintf',
'tcflush',
- 'tcflush',
- 'uname',
- 'wcwidth',
]
have = cc.has_function(sym, args : '-D_GNU_SOURCE')
conf.set10('HAVE_' + sym.to_upper(), have)