summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2019-02-12 11:17:30 +1000
committerAllan McRae <allan@archlinux.org>2019-02-12 11:29:13 +1000
commit86004227d14bef059f71290b3c0454ad88ea0f86 (patch)
tree6876053a8632521131d72b9654994b68973aa491 /meson.build
parentdb102c67efe9cfd4367a9110c8f97ceff5afcbe3 (diff)
downloadpacman-86004227d14bef059f71290b3c0454ad88ea0f86.tar.gz
pacman-86004227d14bef059f71290b3c0454ad88ea0f86.zip
Add implicit fall through warning
Requires modification to our comment about fall through to match compilers expectations. Works for GCC and Clang. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0a710653..02a3a3d3 100644
--- a/meson.build
+++ b/meson.build
@@ -220,6 +220,7 @@ if get_option('buildtype').startswith('debug')
'-Wformat-nonliteral',
'-Wformat-security',
'-Wignored-qualifiers',
+ '-Wimplicit-fallthrough',
'-Winit-self',
'-Wlogical-op',
'-Wmissing-declarations',