summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2020-05-05 00:41:09 -0400
committerAllan McRae <allan@archlinux.org>2020-05-06 13:48:07 +1000
commit3a6c9220fffe1836f2f1b8e8618543791bd3901f (patch)
tree5a2b4cc8c421e41015a1525ea61798c7a9d2486a /meson.build
parentdf30f10672ba46a34521d6a503e8a1764d4795cc (diff)
downloadpacman-3a6c9220fffe1836f2f1b8e8618543791bd3901f.tar.gz
pacman-3a6c9220fffe1836f2f1b8e8618543791bd3901f.zip
meson: use better check for debug builds
meson 0.48 added the 'debug' and 'optimization' builtin options, which bidirectionally map to the buildtype, but in some cases where debug is enabled, the builtype may be custom. Checking the 'debug' option lets us detect every case currently detected, plus a few more, and does so in a shorter and more concise manner. Signed-off-by: Eli Schwartz <eschwartz@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 572526b2..680cf62b 100644
--- a/meson.build
+++ b/meson.build
@@ -177,7 +177,7 @@ elif conf.has('HAVE_STRUCT_STATFS_F_FLAGS')
conf.set('FSSTATSTYPE', 'struct statfs')
endif
-if get_option('buildtype').startswith('debug')
+if get_option('debug')
extra_cflags = [
'-Wcast-align',
'-Wclobbered',