summaryrefslogtreecommitdiffstats
path: root/test
diff options
context:
space:
mode:
authorLukas Fleischer <lfleischer@archlinux.org>2016-10-08 14:19:11 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2016-10-08 14:25:43 +0200
commitd4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2 (patch)
tree509f59c92a2a555a1e743f0ea689c5766c36319a /test
parente182ba0c42a9d2b2afecb8da32d00f634999935e (diff)
downloadaur-d4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2.tar.gz
aur-d4fe77ac572ef0e60c9ffa5f987c9cda448cf9f2.zip
Reorganize Git interface scripts
Move the Git interface scripts from git-interface/ to aurweb/git/. Use setuptools to automatically create wrappers which can be installed using `python3 setup.py install`. Update the configuration files, the test suite as well as the INSTALL and README files to reflect these changes. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'test')
-rw-r--r--test/setup.sh8
1 files changed, 4 insertions, 4 deletions
diff --git a/test/setup.sh b/test/setup.sh
index dc9cff2..d02d298 100644
--- a/test/setup.sh
+++ b/test/setup.sh
@@ -8,9 +8,9 @@ PYTHONPATH="$TOPLEVEL"
export PYTHONPATH
# Configure paths to the Git interface scripts.
-GIT_AUTH="$TOPLEVEL/git-interface/git-auth.py"
-GIT_SERVE="$TOPLEVEL/git-interface/git-serve.py"
-GIT_UPDATE="$TOPLEVEL/git-interface/git-update.py"
+GIT_AUTH="$TOPLEVEL/aurweb/git/auth.py"
+GIT_SERVE="$TOPLEVEL/aurweb/git/serve.py"
+GIT_UPDATE="$TOPLEVEL/aurweb/git/update.py"
MKPKGLISTS="$TOPLEVEL/scripts/mkpkglists.py"
TUVOTEREMINDER="$TOPLEVEL/scripts/tuvotereminder.py"
PKGMAINT="$TOPLEVEL/scripts/pkgmaint.py"
@@ -38,7 +38,7 @@ reply-to = noreply@aur.archlinux.org
[auth]
valid-keytypes = ssh-rsa ssh-dss ecdsa-sha2-nistp256 ecdsa-sha2-nistp384 ecdsa-sha2-nistp521 ssh-ed25519
username-regex = [a-zA-Z0-9]+[.\-_]?[a-zA-Z0-9]+$
-git-serve-cmd = /srv/http/aurweb/git-interface/git-serve.py
+git-serve-cmd = $GIT_SERVE
ssh-options = restrict
[serve]