summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Fleischer <lfleischer@archlinux.org>2018-07-07 16:04:39 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2018-07-07 16:05:12 +0200
commit840ee20f7b9327fd5e3445af2652b299fdd0ff7f (patch)
tree69a4a2000a25d04e2d719f64c3fd1cbe655a9611
parent41a4189d2078e1571d784068e34e7a753bcb8f22 (diff)
downloadaur-840ee20f7b9327fd5e3445af2652b299fdd0ff7f.tar.gz
aur-840ee20f7b9327fd5e3445af2652b299fdd0ff7f.zip
Rename translation resources from aur to aurweb
* Rename the aur project to aurweb on Transifex. * Rename aur.pot to aurweb.pot. * Update documentation and Makefile. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
-rw-r--r--.tx/config5
-rw-r--r--doc/i18n.txt8
-rw-r--r--po/Makefile16
-rw-r--r--po/aurweb.pot (renamed from po/aur.pot)0
4 files changed, 14 insertions, 15 deletions
diff --git a/.tx/config b/.tx/config
index f6f728d..e986f81 100644
--- a/.tx/config
+++ b/.tx/config
@@ -1,8 +1,7 @@
[main]
host = https://www.transifex.com
-[aur.aurpot]
+[aurweb.aurwebpot]
file_filter = po/<lang>.po
-source_file = po/aur.pot
+source_file = po/aurweb.pot
source_lang = en
-
diff --git a/doc/i18n.txt b/doc/i18n.txt
index a1c21fe..8216c08 100644
--- a/doc/i18n.txt
+++ b/doc/i18n.txt
@@ -5,7 +5,7 @@ This document describes how to create and maintain aurweb translations.
Creating an aurweb translation requires a Transifex (http://www.transifex.com/)
account. You will need to register with a translation team on the aurweb
-project page (http://www.transifex.com/projects/p/aur/).
+project page (http://www.transifex.com/projects/p/aurweb/).
Creating a New Translation
@@ -26,11 +26,11 @@ $ git clone git://git.archlinux.org/aurweb.git aurweb-git
2. Go into the "po/" directory in the aurweb source and run msginit(1) to
create a initial translation file from our translation catalog:
-$ cd aur-git
+$ cd aurweb-git
$ git checkout master
$ git pull
$ cd po
-$ msginit -l <locale> -o <locale>.po -i aur.pot
+$ msginit -l <locale> -o <locale>.po -i aurweb.pot
3. Use some editor or a translation helper like poedit to add translations:
@@ -58,4 +58,4 @@ $ poedit po/<locale>.po
3. Push the updated translation file back to Transifex. Using transifex-client,
this works as follows:
-$ tx push -r aur.aurpot -t -l <locale>
+$ tx push -r aurweb.aurwebpot -t -l <locale>
diff --git a/po/Makefile b/po/Makefile
index 78073f8..57fa9f7 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -44,9 +44,9 @@ all: ${MOFILES}
%.mo: %.po
msgfmt --check -o $@ $<
-%.po-update: %.po aur.pot
+%.po-update: %.po aurweb.pot
lang=`echo $@ | sed -e 's/\.po-update$$//'`; \
- msgmerge -U --no-location --lang="$$lang" $< aur.pot
+ msgmerge -U --no-location --lang="$$lang" $< aurweb.pot
POTFILES-php:
find ../web -type f -name '*.php' -printf '%P\n' | sort >POTFILES-php
@@ -55,19 +55,19 @@ POTFILES-py:
find ../aurweb -type f -name '*.py' -printf '%P\n' | sort >POTFILES-py
update-pot: POTFILES-php POTFILES-py
- pkgname=AUR; \
+ pkgname=AURWEB; \
pkgver=`sed -n 's/.*"AURWEB_VERSION", "\(.*\)".*/\1/p' ../web/lib/version.inc.php`; \
- xgettext --default-domain=aur -L php --keyword=__ --keyword=_n:1,2 \
+ xgettext --default-domain=aurweb -L php --keyword=__ --keyword=_n:1,2 \
--add-location=file --add-comments=TRANSLATORS: \
--package-name="$$pkgname" --package-version="$$pkgver" \
--msgid-bugs-address='${MSGID_BUGS_ADDRESS}' \
- --directory ../web --files-from POTFILES-php -o aur.pot; \
- xgettext --default-domain=aur -L python --join-existing \
+ --directory ../web --files-from POTFILES-php -o aurweb.pot; \
+ xgettext --default-domain=aurweb -L python --join-existing \
--keyword=translate \
--add-location=file --add-comments=TRANSLATORS: \
--package-name="$$pkgname" --package-version="$$pkgver" \
--msgid-bugs-address='${MSGID_BUGS_ADDRESS}' \
- --directory ../aurweb --files-from POTFILES-py -o aur.pot
+ --directory ../aurweb --files-from POTFILES-py -o aurweb.pot
update-po:
${MAKE} ${UPDATEPOFILES}
@@ -77,7 +77,7 @@ clean:
install: all
for l in ${LOCALES}; do mkdir -p ${DESTDIR}${PREFIX}/$$l/LC_MESSAGES/; done
- for l in ${LOCALES}; do cp $$l.mo ${DESTDIR}${PREFIX}/$$l/LC_MESSAGES/aur.mo; done
+ for l in ${LOCALES}; do cp $$l.mo ${DESTDIR}${PREFIX}/$$l/LC_MESSAGES/aurweb.mo; done
uninstall:
for l in ${LOCALES}; do rm -rf ${DESTDIR}${PREFIX}/$$l/LC_MESSAGES/; done
diff --git a/po/aur.pot b/po/aurweb.pot
index e49dc13..e49dc13 100644
--- a/po/aur.pot
+++ b/po/aurweb.pot