summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Fleischer <lfleischer@archlinux.org>2017-08-25 06:59:56 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2017-08-25 07:04:15 +0200
commit36f26033d8505576041467ec3d8d6204d65e2025 (patch)
tree02212178030bd8f0ee629d8106e7592c7e9880c2
parent7ef1427678f754de128d4fb34f9fe6011cba1218 (diff)
downloadaur-36f26033d8505576041467ec3d8d6204d65e2025.tar.gz
aur-36f26033d8505576041467ec3d8d6204d65e2025.zip
Add basic Travis CI support
Add a Travis CI configuration file to setup a test environment with all the required dependencies and run the test suite. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
-rw-r--r--.travis.yml23
1 files changed, 23 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..5bbfda1
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,23 @@
+language: python
+
+python: 3.6
+
+addons:
+ apt:
+ packages:
+ - bsdtar
+ - libarchive-dev
+ - libgpgme11-dev
+ - libprotobuf-dev
+
+install:
+ - curl https://codeload.github.com/libgit2/libgit2/tar.gz/v0.26.0 | tar -xz
+ - curl https://sources.archlinux.org/other/pacman/pacman-5.0.2.tar.gz | tar -xz
+ - curl https://git.archlinux.org/pyalpm.git/snapshot/pyalpm-0.8.1.tar.gz | tar -xz
+ - ( cd libgit2-0.26.0 && cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr && make && sudo make install )
+ - ( cd pacman-5.0.2 && ./configure --prefix=/usr && make && sudo make install )
+ - ( cd pyalpm-0.8.1 && python setup.py build && python setup.py install )
+ - pip install mysql-connector-python-rf pygit2==0.26 srcinfo
+ - pip install bleach Markdown
+
+script: make -C test