path: root/todolists
AgeCommit message (Collapse)AuthorFilesLines
2010-06-02Rename todolist email templateDan McGee1-1/+1
More in line with our other templates that have .txt extensions. Signed-off-by: Dan McGee <>
2010-05-21Fix undefined variable issueDan McGee1-1/+1
Signed-off-by: Dan McGee <>
2010-04-02Fix package URL in todo list emailsDan McGee1-1/+1
Fixes FS#18935. Signed-off-by: Dan McGee <>
2010-03-29Fix todolist dealing with package maintainersDan McGee1-3/+3
Forgot to update this, whoops. Signed-off-by: Dan McGee <>
2010-03-06Use repo.testing flag instead of test-based checksDan McGee1-1/+1
Signed-off-by: Dan McGee <>
2010-03-01Unify spelling of 'Todo'Dan McGee1-3/+3
We used 'Todo', 'ToDo', and 'To-do' in different places. Unify them all to the first. Signed-off-by: Dan McGee <>
2010-02-27Ensure our cache is correct with AJAX requestsDan McGee1-0/+2
Since the same URLs serve two different responses based on the request being AJAX or not, we want to ensure we don't cache the wrong one and serve it up incorrectly. Signed-off-by: Dan McGee <>
2010-02-26Implement AJAX flagging for todo itemsEvangelos Foutras1-6/+11
[Some trailing whitespace got killed in the process. :3] Dan: I made a few small changes including moving the jQuery include down above the other script block; since it is not needed right away it can be loaded later in the page. Signed-off-by: Evangelos Foutras <> Signed-off-by: Dan McGee <>
2010-02-10Remove archweb prefix from all importsDan McGee1-1/+1
Unnecessary, and lets us standardize on not using it everywhere. Signed-off-by: Dan McGee <>
2010-01-31Use select_related() to make a few more places more performantDan McGee1-1/+1
Especially when looking at packages, we always want the arch and repo. Another big hunk of changes deals with the very inefficient signoffs code. Signed-off-by: Dan McGee <>
2010-01-31Adjust models and views for nullable maintainerEvangelos Foutras1-1/+1
Signed-off-by: Evangelos Foutras <> [Dan: made a few other small touchups] Signed-off-by: Dan McGee <>
2010-01-30Exclude repos ending with "Testing" from ToDosEvangelos Foutras1-1/+2
This should fix the issue with Community-Testing packages appearing in ToDo lists. After this change has been applied, simply edit and save a ToDo list to make its Community-Testing packages go away. Signed-off-by: Dan McGee <>
2009-11-10added login_required to protect todolists viewsIsmael Carnales1-1/+4
2009-11-09fixed error in todolists list viewIsmael Carnales1-2/+2
2009-11-09modified import paths from archweb_dev to archwebIsmael Carnales1-1/+1
2008-10-11drop some print statementsDusty Phillips1-3/+1
2008-10-10use RequestContext because its standardDusty Phillips1-9/+9
2008-10-10port to django 1.0Dusty Phillips1-12/+14
2008-10-05drop a bunch of unusued importsDusty Phillips1-1/+1
2008-10-05drop some unused importsDusty Phillips1-5/+2
2008-07-22fix problem with to-do list showing testing packagesDusty Phillips1-1/+1
2008-07-08fix up permissions on todolistsDusty Phillips1-2/+2
2008-07-01stupid stupid variable overwriteDusty Phillips1-4/+9
2008-07-01mistakeDusty Phillips1-1/+1
2008-07-01missing importDusty Phillips1-0/+1
2008-07-01add reminder e-mails to todo listsDusty Phillips1-2/+25
2008-06-29fix problem with deleting packages from a listDusty Phillips1-0/+6
2008-06-27refactor package cleaning to be duplicate sensitiveDusty Phillips1-6/+5
2008-06-27add an 'edit todolist' functionalityDusty Phillips1-0/+32
2008-06-27refactor todo packages a bitDusty Phillips1-8/+3
2008-06-27use newforms on todo listDusty Phillips1-24/+41
2008-06-27better exception handlingDusty Phillips1-2/+4
2008-06-27use a nicer decoratorDusty Phillips1-2/+2
2008-04-09Removed login_required from the individual views.eliott1-5/+1
Not entire dev site requires login.
2008-04-09Changed to arches and repos in the db.eliott1-0/+1
Added them to the django admin interface as well.
2008-04-05small fix to todolistseliott1-5/+8
2008-03-08More changes to the multiarch model.eliott1-1/+1
2008-03-08Moved models aroundeliott2-36/+2
2007-12-29Massive retab fest.eliott2-21/+26
Also added vim command comment to the end of files.
2007-12-29Modified render_template and renamed it to render_response (consistent witheliott1-39/+38
archweb_pub conventions). Moved pkgmaint_guide to a template.
2007-12-22renamed importseliott2-4/+4
2007-11-03Initial import for public release...eliott3-0/+95
Special Note Prior to git import, approx 90% of the code was done by Judd Vinet. Thanks Judd!